Присоединяйтесь к онлайн-школе и получайте бонусы за интересные сообщения и другие действия!

ЗНАНИЯ

Конструкция: Повторение (цикл) (проверка в начале)

Есть еще один интересный и очень полезный механизм - это цикл или повторение. Он позволяет программе многократно повторять какой-то блок, пока не будет получен результат.

Записывается цикл так:

нц пока <условие>

<что должно происходить в цикле>

кц

Т.е. в начале - начало цикла (нц), а в конце - конец цикла (кц).

Простейший пример:

цел A := 1

нц пока А < 5

А := А+1

кц

Пояснение программы:

Мы создали целую переменную «А» и сразу присвоили ей значение 1.

Начали цикл и объявили условие, что пока «А» меньше 5, будет выполняться цикл.

В цикле выполняется новое прибавление к прошлому значению «А» единицы (было 1, станет 2; было 2, станет 3 и т.д.).

Конец цикла. Программа выполняет следующие команды.

Т.е. цикл будет начинаться с проверки значения «А», если оно меньше 5, то начинается его выполнение.

Выполняется подпрограмма внутри цикла (в теле цикла), возвращается в начало и опять проверяет.

И так, пока «А» не станет равно 5. Потому что при третьем повторе, у нас получится цифра 4 и цикл начнется заново, ведь 4 меньше 5. К «А» снова добавится единица и переменная «А» станет равна 5.

​​​​​​​konstrukciya-povtorenie-cikl-proverka-v-nachale

Ну, или пример, ближе к человеческому:

цел количествоПриседаний := 0

нц пока количествоПриседаний < 10

количествоПриседаний := количествоПриседаний +1

кц

Соответственно, приседаем, пока не присели 10 раз.

<< Предыдущий урок
ОПЫТ:

Задание 1

При правильном ответе Вы получите 3 балла

Какие циклы встречаются в нашей жизни?

Выберите те ответы, которые считаете верными.

Ответить
Следующий урок >>

Комментарии:

Добавление комментариев доступно только зарегистрированным пользователям